Вход | Регистрация
    1  2  3
Работа :: Работа

ОГОНЬ! Ранис Усманов собеседует Павла Чистова

↓ [Волшебник, 27.09.20 - 07:50]
ОГОНЬ! Ранис Усманов собеседует Павла Чистова
Я
   Фабрикантъ
 
24.09.20 - 20:55
ОГОНЬ! Павел Чистов (тот самый, ага! - который писал курс по подготовке к 1С:Специалисту по платформе - chistov.pro ) на собеседовании у Раниса Усманова!

https://www.youtube.com/watch?v=bMeUk8WdimM&feature=youtu.be
   Конструктор1С
 
201 - 25.09.20 - 19:16
(197) на самом деле чувак прав, по крайней мере отчасти. 1сная отрасль отстаёт от тру-программирования. Сейчас 1сное программирование переживает те "болячки", которыми тру-программирование переболело ещё лет 10-15 назад
   mistеr
 
202 - 25.09.20 - 19:16
(196) Ты до конца посмотрел? Там не 95%.

Другое дело, что это не реальное собеседование, а прикол двух друзей, с попутной рекламой. На реальном Пашу бы завалили, не зная, что он Чистов.
   Конструктор1С
 
203 - 25.09.20 - 19:17
+(201) это издержки собственного "уникального" пути развития
   H A D G E H O G s
 
204 - 25.09.20 - 19:18
Но обычно (199) тупо мисдят из открытых источников, более-менее внушающих доверие, имеют секс с некомпиляцией под текущей средой, бегло просматривают на бэкдоры и помолясь, втыкают в продакшн.
   Конструктор1С
 
205 - 25.09.20 - 19:18
(202) до конца было лень смотреть, меня еле хватило на 25 минут)
   mistеr
 
206 - 25.09.20 - 19:20
(199) Не совсем так. Во взрослом программировании все эти задачи тоже уже решены. И не один раз, что конечно добавляет муки выбора. :) Но если вдруг что-то низкоуровневое работает не так, как ожидается, ты открываешь код и смотришь что же там происходит. Или просто пишешь чуваку, который это написал, и он отвечает.

Сравни с аналогичным квестом у нас.
   Фрэнки
 
207 - 25.09.20 - 19:24
(202) На реальном его бы все равно дослушали до конца, конечно, если это приличная компания. И он бы даже не догадался, на скольких вопросах он завалился.
А вот взяли бы его или нет - это трудно сказать. Если на работу кодером... ну может и не взяли бы.
   Garykom
 
208 - 25.09.20 - 19:25
(206) Во взрослом программировании при реализации учетной системы начинают придумывать "платформу 1С" ))
   mTema32
 
209 - 25.09.20 - 19:26
Я тож все не осилил. И это больше похоже не на собеседование, а на некий срез знаний Павла. Только возникает вопрос: нахера в 21м веке мне знать чем отличается соответствие от структуры? Все знания доступны в телефоне. Какой смысл держать в голове энциклопедические знания, особенно такие, которыми не пользуешься. Я с 2008 года работаю и ни разу мне не приходилось допиливать например регистр расчета или бухгалтерии. Да даже регистр накопления почти не трогал. И на кой забивать голову тем как они работабт сейчас мне? Абсолютно фиолетово. Когда надо будет - я разберусь.
В контору где реально так собеседуют я бне пошел работать. Ибо методы зазубрить что-то крайне неэффективны.
И да, можете помидоры кидать, я использую запросы в циклах. Не всегда, но такое бывает необходимо.
   Garykom
 
210 - 25.09.20 - 19:26
(208)+ Вот есть во многих sql базах данных/движках/серверах ссылочная целостность.
Гы и почти никто не использует и начинает изобретать свои лисапеды.
   H A D G E H O G s
 
211 - 25.09.20 - 19:29
(206) Даже Google забивает на свои среды болт и точно также тягомотит с ошибками месяцами.
   H A D G E H O G s
 
212 - 25.09.20 - 19:30
(209) Чем структура отличается от соответствия?
   Garykom
 
213 - 25.09.20 - 19:31
1С очень сильно не хватает поддержки общемирового сообщества.

Была бы некая версия платформы 1С "бесплатной", пусть и урезанной по функционалу но с возможностью реальной работы то оно бы быстро было вылизано до почти идеала.

А 1С могла бы рубить бабло на удобных инструментах (тот же EDT сделать платным - гы я бы посмотрел кто купит) или разные фишки типа шины и прочих частей платформы.
   Фрэнки
 
214 - 25.09.20 - 19:33
(212) Результатов: примерно 3 350 000 (0,59 сек.)
Различия Основное отличие между коллекциями заключается в том, что для коллекции типа «Структура», ключ может содержать ТОЛЬКО значение СТРОКОВОГО типа, в то время как ключ в коллекции «Соответствие» может содержать значение ссылочного типа.7 июн. 2017 г.

Отличие структуры от соответствия в «1С»
   H A D G E H O G s
 
215 - 25.09.20 - 19:33
(213) 1С Учебная версия. Бесплатна и урезана.
Но на самом деле - да.
Полгода бесплатности, по аналогии с SQL Enterprise было бы идеалити.
   Фрэнки
 
216 - 25.09.20 - 19:33
(212) т.е. строго говоря Павел и на этот вопрос ответил неточно.
   Garykom
 
217 - 25.09.20 - 19:33
(212) Спорим одно является в ООП потомком другого?
   Garykom
 
218 - 25.09.20 - 19:34
(215) Учебная не туда урезана.
Ввели бы реальные ограничения ну там не более ляма в справочнике и не более 10 лямов в документах и оно бы взлетело!
   H A D G E H O G s
 
219 - 25.09.20 - 19:34
(217) Есть только как наследники TList, это скорее всего их общий предок.
   H A D G E H O G s
 
220 - 25.09.20 - 19:35
(218) Про учебную был сарказм.
   Garykom
 
221 - 25.09.20 - 19:36
(219) Гыгы строка же подмножество объектов.
В Соответствии ключ - объект, в Структуре только строка и добавлена фишка обращения
МояСтруктура.Ключ вместо общепринятой МоеСоответствие["Ключ"]
   Конструктор1С
 
222 - 25.09.20 - 19:36
(212) можно я, можно я?! Где-то читал, что соответствие это "особая" коллекция в платформе 1с, на ней завязана изрядная часть механизмов самой платфомы. Поэтому она очень оптимизирована, и является самой быстрой индексированной коллекцией в 1с. Т.е. поиска быстрее чем в соответствии в платформе нет
   H A D G E H O G s
 
223 - 25.09.20 - 19:36
Я бы взял ориентиром SQL. Один в один.

Как по размерам/процессорам в версии Express, так по полгода бесплатности в версии Enterprise.
   Garykom
 
224 - 25.09.20 - 19:38
(223) Пофиг но нужна замануха. Чтобы любой китаец мог себе наваять в большой корпе замену екселю с его VBA.
   H A D G E H O G s
 
225 - 25.09.20 - 19:44
(221) Структура - это скорее всего TList из 2 колонок - Ключ строкой и АдресОбъекта
Соответствие - это скорее всего BTree из 3 колонок ХэшКлюча, АдресКлюча, АдресОбъекта.
   H A D G E H O G s
 
226 - 25.09.20 - 19:45
Попробуйте получить значение из Структуры размером в 10000 элементов, вы будете удивлены.
   mistеr
 
227 - 25.09.20 - 19:45
(222) Это по-моему не менее важно, чем тип ключа. Соответствие оптимизировано для быстрого поиска для большого количества объектов. Если эти два момента не указал, то на вопрос полностью не ответил.
   Конструктор1С
 
228 - 25.09.20 - 19:57
(225) насколько я понимаю, соответствие это что-то вроде хэш-таблицы. Фишка хэш-таблицы в том, что скорость поиска зависит не линейно от объёма данных. Допустим, найти значение в массиве из 100 тыщ элементов займёт 1 секунду, а поиск среди 1 миллиона элементов займёт 10 секунд, тут зависимость линейная. У хэш-таблиц иначе, поиск среди 100 тыщ займёт условно 0,1 секунду, а среди 10 миллионов условно 0,3 секунды. Т.е. приращение времени не пропорционально объёму данных
   H A D G E H O G s
 
229 - 25.09.20 - 20:00
   Конструктор1С
 
230 - 25.09.20 - 20:04
(229) ай, ладно)
 
 Рекламное место пустует
   Креатив
 
231 - 25.09.20 - 20:08
Почитал немного комментариев и видео смотреть не стал. Звёзд маловато.
Кодирование в 1с напоминает мне угадайку. Пишешь код в надежде, что он будет работать, а потом смотришь, как извратиться, чтобы обойти ограничения.
   RomanYS
 
232 - 25.09.20 - 20:08
(226) Чем?
   experimentator76
 
233 - 25.09.20 - 20:15
(212) к всему вышесказанному я бы добавил правила именования ключа у соотвествия, так же как и для именований переменных.
нельзя начинать с цифр и иметь пробелы между словами... может еще что-то эдакое с именованием - по-моему помню с курсов 1с каких-то :)
   experimentator76
 
234 - 25.09.20 - 20:18
(0) поначалу задавал низкоуровневые технические вопросы, но потом стал давать тестовое задание - главное чтобы человек был хороший, а испытательный срок и умение гуглить дополнят впечатление :)
   BeerHelpsMeWin
 
235 - 25.09.20 - 21:02
(209) >нахера в 21м веке мне знать чем отличается соответствие от структуры?
"нахера мне в 21м веке знать чем документ отличается от справочника?"

Ну должен же быть какой-то базовый уровень знаний.
   ILM
 
236 - 26.09.20 - 07:21
Посмотрел видео и мне что-то грустно стало. Сидят два человека, беседуют, один задает вопросы с монитора, где есть все ответы, а другой пытается вспомнить, то что знает, но не может. Потом один дает оценку другому, и дает рекомендации  "всем" на что обратить внимание и т.д.
Сейчас найти гуру, который знает в 1С и 7.7. и 8.3 и мобильные и ЕРП и т.д. и т.п - это нужно очень-очень постараться.
Чем то это собеседование мне напомнило игру викторину на ТВ где вся семья пытается ответить на вопросы ведущего, а отец семьи кричит "Дальше", "Дальше" ))). Поэитому мое личное мнение к такому собеседованию очень отрицательное - это как попытка всех привести под одну гребенку или под один стандарт.
Я может не смогу сходу написать обработчик правила в КД2  "при получении данных", но минут за 15 в документации найду и сделаю, как и многие другие вещи в 1С. Зато у мнея есть опыт и практика решения кучи прикладных задач и проектов: абонентский отдел водоканала, ТОИР, системы КР в ЖКХ для городской УК, бюджетирования группы предприятий, постановка Бух и Налогового учета, ЗУП, интеграция с Компасом-3D, PERCO-S-20, MES и др.
Я сейчас в одно лицо решаю все вопросы по 1С для ГК из 5-ти предприятий, у нас и ГОЗ, и ЕРП, и УПП.
Но вот "такое" собеседование точно не пройду, я не помню всё  в 1С, а кое с чем сталкивался только при упоминании об этом на мисте или ИТС.
   Eeeehhhh
 
237 - 26.09.20 - 08:32
(236) ну дык это собеседование для франча. А там руководство чаще всего еб.нутое им важно, что бы чел сдал спеца, если у него его нет, а не что бы удовлетворил Марью Ивановну по закрытию месяца в ЕРП.
PS: у меня на удаленке сейчас 1С 7.7 (огромная ТИС перепиляннная на 1С++),  клиент с ЕРП и клиент с мобильным складским ПО на 1С для WMS в связке с какой то самописной WMS и дедушкой, которое это богатство разработал (не хотят переползать на 1С).
PSS: опыт не всегда полезен. У меня несколько внедрений Инталева, но вот я недавно смотрел последний их релиз - внедрить самостоятельно не реально, таки нужно изучать, впрочем как и консолидацию - там как по мне без помощи вообще без шансов или очень долго.
   xXeNoNx
 
238 - 26.09.20 - 08:57
(215) скуль dev-версия бесплатна более полугода
   H A D G E H O G s
 
239 - 26.09.20 - 09:05
(238) я про продакшн.
Дев да, должен быть бесплатен, причем без ограничений.
Весь контроль должен быть на страхе начальников ит.
   ILM
 
240 - 26.09.20 - 09:06
(237) Не думаю что только во франч. Просто определение некоторых знаний 1С-ника. Там же предлагается поиск сотрудников и для других организаций.
   NorthWind
 
241 - 26.09.20 - 09:12
(235) самое смешное, что в 1С действительно мало отличий, потому что в 1С это не конструкции языка (как struct в С), а контейнеры, и их состав может меняться динамически во время выполнения. И в принципе можно использовать одно вместо другого. Единственное существенное отличие - к членам структуры мы можем обращаться через точку по правилам языка, соответственно, требуется соблюдать правила идентификаторов языка при именовании. В соответствии в качестве ключа, скорее всего, допустима любая строковая дичь, лишь бы уникальная.
   NorthWind
 
242 - 26.09.20 - 09:19
и еще - при присваивании значения соответствию по новому ключу элемент добавится автоматически, а структура, если я правильно помню, так не работает, там нужно делать операцию добавления нового члена.
   ДенисЧ
 
243 - 26.09.20 - 09:56
(237) Ты у Ежова на удалёнке?
   чувак
 
244 - 26.09.20 - 10:38
Я вижу что татарские ребята боги 1с. Нуралиев, Насипов и теперь Усманов. Кого еще не знаю? ))
   pavig
 
245 - 26.09.20 - 10:55
(199)
"Писать свой модуль передачи текста с клиента на сервер. С обработкой ошибок RFC и прочими шлюховицами.
Потом расширять его до передачи бинарных файлов.
Потом добавлять сжатие.
Многопоточность."

Вот я про то же)
   mistеr
 
246 - 26.09.20 - 10:56
(244) Татарская мафия же.
   pavig
 
247 - 26.09.20 - 11:03
(244)
"Гилёв" - тоже почти татарская фамилия)
А почти татарин - это всё равно что татарин, в общем та же мафия)
   Rio_1c
 
248 - 26.09.20 - 11:12
(244) Я заметил, что не татары, а башкиры боги в 1С.
Уфа - столица одинэсников
   чувак
 
249 - 26.09.20 - 11:15
Наверно 1С это не "1 секунд", а 1" сабантуй") ))
   mTema32
 
250 - 26.09.20 - 11:38
(212) Ничем.
Если говорить про обычное использование данных конструкций в работе. Для разработчика синтаксис только разный.
А если использовать структуру с 10000 элементами и жаловаться, что она тормозит, то проблема не в самой структуре, а в зеркале.
   RomanYS
 
251 - 26.09.20 - 11:56
(226) Так чему удивиться то должны?
Сделал замеры, никакой разницы по скорости между структурой и соответствием на коллекции 10000 элементов НЕТ.
   RomanYS
 
252 - 26.09.20 - 11:56
(250) А почему она должна тормозить?
   mTema32
 
253 - 26.09.20 - 12:46
(252) Я не знаю. Это не мое утверждение. Тут пишут, что соответствие якобы быстрее работает.
   mistеr
 
254 - 26.09.20 - 12:51
(251) Покажи тест.
   mTema32
 
255 - 26.09.20 - 12:56
(235)"Ну должен же быть какой-то базовый уровень знаний."
Такое у вчерашних студентов можно спрашивать. А так приходит человек с 12ю годами опыта работы и ему такое задают. С другой стороны удобно таким образом неадакватных работодателей на взлете отшивать.
   Eeeehhhh
 
256 - 26.09.20 - 14:59
(243) товарища Ежова расстреляли в 1939 году. Других не знаю ))
   mishaPH
 
Модератор
257 - 26.09.20 - 15:10
(0) я вот одного не пойму. Это теперь в норме от бывших работников 1с, которые благодаря 1с теперь что то значат, пинать свою альмаматер и ее сотрудников?
то Горяйнова ушла и потом поливала на всех углах разрабов ЗУПа, то теперь ты.
   RomanYS
 
258 - 26.09.20 - 15:28
(254) вернусь через пару часов, выложу. Код одинаковый, вставка получение через квадратные скобки. Разница в замерах для соответствующих строк в пределах погрешности
   mistеr
 
259 - 26.09.20 - 16:34
(257) А где пинание?
   RomanYS
 
260 - 26.09.20 - 16:42
(254) Получение по ключу вроде даже быстрее в структуре. Замер для 100к

Соответствие
8    Соот.Вставить(Ключ, инд);    100 000    0,397866    6,87
12    Значение = Соот[Ключ];    100 000    0,382672    6,61
13    Соот.Вставить(Ключ, Значение);    100 000    0,289990    5,01
Итого 18.48%

Структура
20    Соот.Вставить(Ключ, инд);    100 000    0,434661    7,50
24    Значение = Соот[Ключ];    100 000    0,272909    4,71
25    Соот.Вставить(Ключ, Значение);    100 000    0,381596    6,59
Итого 18.80%


&НаСервере
Процедура Команда1НаСервере()
    
    Соот = Новый Соответствие;
    Для инд = 1 По 100000 Цикл
        Ключ = "Ключ" + XMLСтрока(инд);
        Соот.Вставить(Ключ, инд);
    КонецЦикла;
    Для инд = 1 По 100000 Цикл
        Ключ = "Ключ" + XMLСтрока(инд);
        Значение = Соот[Ключ];
        Соот.Вставить(Ключ, Значение);
    КонецЦикла;
    
    
    Соот = Новый Структура;
    Для инд = 1 По 100000 Цикл
        Ключ = "Ключ" + XMLСтрока(инд);
        Соот.Вставить(Ключ, инд);
    КонецЦикла;
    Для инд = 1 По 100000 Цикл
        Ключ = "Ключ" + XMLСтрока(инд);
        Значение = Соот[Ключ];
        Соот.Вставить(Ключ, Значение);
    КонецЦикла;
КонецПроцедуры
 
 
   RomanYS
 
261 - 26.09.20 - 16:44
Откуда вообще может быть предположение, что структура МОЖЕТ быть медленнее?
   pavig
 
262 - 26.09.20 - 17:06
(260)
Если честно, всегда думал, что соответствие намного быстрее структуры, так как оно типа "индексировано"...
Теперь для меня мир уже никогда не будет прежним...
   pavig
 
263 - 26.09.20 - 17:07
Получается, что единственным различием структуры и соответствия являются ключи и методы получения значений по этим ключам
   pavig
 
264 - 26.09.20 - 17:07
или что еще:
   pavig
 
265 - 26.09.20 - 17:07
?
   RomanYS
 
266 - 26.09.20 - 17:12
(262) Как я вижу: структура - наследник соответствия, в которого добавили фичу обращения через точку и связанное с этим ограничение на ключ. Всё. Если немного заморочиться, то могли оптимизировать поиск с учетом ограничения (индексировать строки возможно "проще" чем произвольный ключ), но зачем замедлять - представить не могу.
   RomanYS
 
267 - 26.09.20 - 17:14
Дмитирий, расшифруй (226), пожалуйста
   RomanYS
 
268 - 26.09.20 - 17:15
*(267) Дмитрий
   Фрэнки
 
269 - 26.09.20 - 17:15
(265) только это. Ну а сам посуди, есть ключ и значение и все.
И там и там. В чем разница? Разница только в том, что можно использовать в качестве ключа и ... с пользовательской стороны больше никаких отличий нет.

Мало того, если считать, что ссылочный тип на произвольный объект метаданных и данных является просто зарезервированным размером индексированного поля, то вот и вся разница. Строковое представление ключа у структуры заменяется на строковое представление ссылки в ключе у соответствия и все.
   H A D G E H O G s
 
270 - 26.09.20 - 17:17
(267) попробуйте произвольный доступ к стиуктуре.
   H A D G E H O G s
 
271 - 26.09.20 - 17:18
Либо есть оптимизация последовательного доступа, либо они переработали структуру с версии 8.2
   RomanYS
 
272 - 26.09.20 - 17:19
(270) В смысле рандомные ключи? Не вижу принципиальной разницы, сейчас попробую
   H A D G E H O G s
 
273 - 26.09.20 - 17:21
(272) да, рандом
Через пару часов буду дома, потестю.
   RomanYS
 
274 - 26.09.20 - 17:25
(273) Всё тоже самое
Соответствие
14    Значение = Соот[Ключ];    100 000    0,462408    6,80
Структура
26    Значение = Соот[Ключ];    100 000    0,348193    5,12

Процедура Команда1НаСервере()
    ГС = Новый ГенераторСлучайныхЧисел(ТекущаяУниверсальнаяДатаВМиллисекундах());
    Н = 100000;
    
    Соот = Новый Соответствие;
    Для инд = 1 По Н Цикл
        Ключ = "Ключ" + XMLСтрока(инд);
        Соот.Вставить(Ключ, инд);
    КонецЦикла;
    Для инд = 1 По Н Цикл
        Ключ = "Ключ" + XMLСтрока(ГС.СлучайноеЧисло(1,Н));
        Значение = Соот[Ключ];
        Соот.Вставить(Ключ, Значение);
    КонецЦикла;
    
    
    Соот = Новый Структура;
    Для инд = 1 По Н Цикл
        Ключ = "Ключ" + XMLСтрока(инд);
        Соот.Вставить(Ключ, инд);
    КонецЦикла;
    Для инд = 1 По Н Цикл
        Ключ = "Ключ" + XMLСтрока(ГС.СлучайноеЧисло(1,Н));
        Значение = Соот[Ключ];
        Соот.Вставить(Ключ, Значение);
    КонецЦикла;
КонецПроцедуры
   RomanYS
 
275 - 26.09.20 - 17:26
(271) 8.2 нет, могу только режим совместимости влючить
   Guk
 
276 - 26.09.20 - 17:27
смешно. я с Пашей лично знаком, даже пили вместе. но когда его тестирует какой-то абрек, это вызывает умиление...
   RomanYS
 
277 - 26.09.20 - 17:29
   H A D G E H O G s
 
278 - 26.09.20 - 17:30
(275) у меня есть, проверю
   experimentator76
 
279 - 26.09.20 - 17:36
Коллеги

Соответствие явно оптимизировано для объемов

    //Нечто = Новый Структура;
    Нечто = Новый Соответствие;
    
    Ключ = "";
    Для Счетчик = 1 ПО 10000 Цикл
        Ключ = Ключ + "Ключ" + XMLСтрока(Счетчик);
        Нечто.Вставить(Ключ, Счетчик);
    КонецЦикла;

Это код в для структуры отрабатывает медленнее и в отладчике виснет, а соответствие быстрее заполняется и в отладчике открывается почти без тормозов.
Непохоже что структура следует из соответствия.
   Guk
 
280 - 26.09.20 - 17:38
(277) я та к понимаю, что ты идиот...
   experimentator76
 
281 - 26.09.20 - 17:45
(279) изначально я хотел сломать идин из типов чрезмерной длиной строкового ключа, но в итоге получилось что при чтении содержимого типов целиком для отладки - скорость существенно отличается, а это значит что скорее всего типы хранятся и обрабатываются по разному, т.е. не одно и тоже или следствие одного из другого
   experimentator76
 
282 - 26.09.20 - 18:37
+ разница точно есть, не катастрофическая, но типы скорее всего разные "внутри". я бы при больших количествах элементов использовал таблицу значений - она универсальнее :)

Длительность записи в структуру: 49,124
Длительность записи в соответствие: 46,707
Длительность чтения и модификации в структуре: 63,509
Длительность чтения и модификации в соответствии: 61,77

    
    ВсегоЭлементов = 3000000;
    Множитель = 1000000000000000000000000000000;
    
    ВремяНачала = ТекущаяУниверсальнаяДатаВМиллисекундах();
    Структура = Новый Структура;
    Для Счетчик = 1 ПО ВсегоЭлементов Цикл
        Структура.Вставить("Ключ" + Формат(Счетчик, "ЧЦ=200; ЧВН=; ЧГ=0"), Счетчик * Множитель);
    КонецЦикла;
    Сообщить("Длительность записи в структуру: " + Число(ТекущаяУниверсальнаяДатаВМиллисекундах() - ВремяНачала) / 1000);
    
    ВремяНачала = ТекущаяУниверсальнаяДатаВМиллисекундах();
    Соответствие = Новый Соответствие;
    Для Счетчик = 1 ПО ВсегоЭлементов Цикл
        Соответствие.Вставить("Ключ" + Формат(Счетчик, "ЧЦ=200; ЧВН=; ЧГ=0"), Счетчик * Множитель);
    КонецЦикла;
    Сообщить("Длительность записи в соответствие: " + Число(ТекущаяУниверсальнаяДатаВМиллисекундах() - ВремяНачала) / 1000);
    
    
    ВремяНачала = ТекущаяУниверсальнаяДатаВМиллисекундах();
    Для Счетчик = 0 ПО ВсегоЭлементов - 1 Цикл
        Ключ = "Ключ" + Формат(ВсегоЭлементов - Счетчик, "ЧЦ=200; ЧВН=; ЧГ=0");
        Значение = Структура[Ключ];
        Структура.Вставить(Ключ, Значение / Множитель);
    КонецЦикла;
    Сообщить("Длительность чтения и модификации в структуре: " + Число(ТекущаяУниверсальнаяДатаВМиллисекундах() - ВремяНачала) / 1000);
    
    ВремяНачала = ТекущаяУниверсальнаяДатаВМиллисекундах();
    Для Счетчик = 0 ПО ВсегоЭлементов - 1 Цикл
        Ключ = "Ключ" + Формат(ВсегоЭлементов - Счетчик, "ЧЦ=200; ЧВН=; ЧГ=0");
        Значение = Соответствие[Ключ];
        Соответствие.Вставить(Ключ, Значение / Множитель);
    КонецЦикла;
    Сообщить("Длительность чтения и модификации в соответствии: " + Число(ТекущаяУниверсальнаяДатаВМиллисекундах() - ВремяНачала) / 1000);
   2mugik
 
283 - 26.09.20 - 21:17
(68)На Соединении слиянием новая архитектура взаиморасчетов построена. Так что очень актуально.Сливаются реализации и поступления денег. Меня впечатлило.
   vis_tmp
 
284 - 27.09.20 - 09:03
(283) Расскажи поподробнее?
   2mugik
 
286 - 27.09.20 - 14:19
(284)https://its.1c.ru/db/updinfo#content:593:1:issogl2_toc527387963
Если в коде посмотреть - при проведении документа берут с начала дня даты документы приходы денег в одну таблицу, реализации в другую. сортируют таблицы. сливают как в сортировке слиянием. тем самым гасят поступления денег реализациями и наоборот. и никакаких последовательностей или перепроведений.
   H A D G E H O G s
 
287 - 27.09.20 - 15:02
(274) Признаю свою вину, структура не деградирует по производительности по крайней мере в 8.3/8.2
Однако я сталкивался с этим, вот только не помню в какой версии платформы, возможно даже в 8.1.
Но, к сожалению, 8.1 не знает про программные лицензии и запустить ее пока нет шансов.
   Конструктор1С
 
288 - 27.09.20 - 15:50
Господа, ваши тесты ну ни разу не валидные
   RomanYS
 
289 - 27.09.20 - 16:43
(288) что не так?
   Конструктор1С
 
290 - 27.09.20 - 18:58
(289) ключи слишком уж похожы друг на друга
   RomanYS
 
291 - 27.09.20 - 19:53
(290) Вряд ли что-то поменяется. Возможно вставка будет медленнее (типа перестроение индексов), получение по ключу скорее всего не поменяется.
И в любом случае изменения будут одинаковые для структуры и соответствия. Если конечно не делать ключи длиной в 100к как в (279).
   H A D G E H O G s
 
292 - 27.09.20 - 20:41
(290) Я на основе UUID ключи делал
   Конструктор1С
 
293 - 28.09.20 - 06:17
(292) миллион ключей рандомной длины от 10 до 100 символов, полученные из склеивания UUIDов, дали вот такой результат:

Вставка в Структура: 15,366
Поиск в Структура: 12,975
Вставка в Соответствие: 11,699
Поиск в Соответствие: 12,034

всё-таки соответствие быстрее. Но видимо структуру оптимизировали, раньше разница была заметнее. Надо будет на 8.1 и 8.2 попробовать
   RomanYS
 
294 - 28.09.20 - 10:30
(293) код покажи.
Ну и при таких результатах я бы не стал утверждать, что однозначно "соответствие быстрее".
   MadHead
 
295 - 29.09.20 - 06:52
(282) Для чистоты эксперемента можно протестировать в обратном порядке и упростить расчет значений. Расчет значений для вставки может отъедает не мало ресурсов.
Вполне вероятно, что обе колекции - это хэш таблицы, просто у них разные алгоритмы расчета хэша.
   MadHead
 
296 - 29.09.20 - 06:55
(295) Деревья обычно ипспользуют что бы получить возможность сортировки. На сколько я помню ни структура, ни соответствие не поддерживает сортировку.
   rphosts
 
297 - 29.09.20 - 06:55
Посмотрел минут 50 (остальное на вечер).... да я практически столько-же знаю сколько сам Чистов! И да, с обменами есть небольшой провал ибо только теоретически... ну и да, историяю и назначение общих и настраиваемых реквизитов не знал.
А что так мало просмотров-то? Всего 8,5К!
   rphosts
 
298 - 29.09.20 - 06:57
(296) сортировка по соответствию (где ключ почти любая мыслимая хрень) это звучить уже забавно
  1  2  3

Список тем форума
  Рекламное место пустует
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
В секцию Работа можно добавлять сообщения только после регистрации на форуме.
Если вы уже зарегистрированы, вам нужно войти на форум.